Archor fails to log in to AtomicHub

My archor opens on the computer perfectly but when I try to log in to AtomicHub, click open wallet, it opens normally, but does not log in to the atomichub platform.

image
When clicking on debug sometimes this error appears,

Which version of Anchor desktop is this?

It’s possible an upgrade might fix it. The app is on version 1.1.12 now.

when I noticed this bug I updated it and now my version 1.1.12
and still didn’t fix the bug

I’d be curious to know what the status of your wallet is if you go into Tools and then into Link Service after the wallet has been running for a minute or so.

If you wouldn’t mind sharing a screenshot, it’d look something like this:

No problems

Interesting - and you’re getting the login prompt, and signing the transaction successfully?

What happens on AtomicHub, any errors on that side? If they aren’t visible errors, there may be some errors in the browser itself that may help troubleshoot what’s going on. If you hit F12 it’ll open the developer tools - and then try to login while looking at the “Console” tab of that. Any errors in there might help track this down.

When clicking on the atomic login, i am not receiving a transaction to enter my password, the anchor simply opens directly, but does not log into, atomic just on the desktop
pressing f12 appears this here

image

Those look to be Scatter errors and unrelated - which happen always on sites like atomic.

One thing to check would be to make sure you have this enabled:

I’m still struggling to figure out where the process you’re getting stuck exactly. For reference, the entire login flow should look like this:

  1. Click Login in AtomicHub.
  2. Select Anchor from the options.
  3. Click Launch Anchor below the QR code.
  4. Sign the transaction to prove your identity.

Which part exactly is it you’re stuck at?

Yes my wallet is the same as yours in the first photo
the 4 item does not exist for me
when I do all these steps, I don’t get that tab to confirm my identity

Which operating system?

One thing to also try is in that first photo, disable App Integration, and then re-enable it.

Microsoft Windows
I’ve done this several times and just tried again
now when clicking on desbug it appears here
image
I’m thinking of deleting it and trying to download it again, as I have the secret key if I don’t remember the password I can recover anyway

Alright - there’s a number of things it could be, some related to security settings as well.

Anchor uses a custom URI to launch the initial handshake between dapp and wallet. That seems to be the part that’s not working on your computer. It’s similar to a mailto: link you’ve probably clicked on in the past that opens your email client, except ours look like this:

esr://gmNgZACDVwahBaKXOu-tMrrLCBViYILSgjCBBUZ3JaRfXk1lAAoAAA

Clicking on the above should launch an Anchor signing request to vote for our proxy. The same should be true if you copied the link and pasted it in your web browser. I assume this link doesn’t work for you either?

If that’s the case, it might even be the browser that’s interfering with it. I have seen instances where either Chrome Extensions or Brave and its security settings have blocked these types of links from working. That could be an area we could start troubleshooting.

Already try to open Chrome, Edge and opera did not work with any
And this link that you send also didn’t work
I can do everything normal, the only problem that when trying to log in to atomic I don’t get the link to confirm my identity

Alright - if none of those work at all, then it’s definitely a setting on the computer itself that’s preventing these types of links from working. It could be antivirus/antimalware software on the machine, a network policy that’s being applied to Windows by admins, or even Windows security settings (which I’m trying to research a bit).

This isn’t an ideal way of doing it, but one option you can use to login right now would be to copy the link behind the “Launch Anchor” button by right clicking on it, like so:

Leave that window with the QR code and link open - since it’s sitting there waiting for you to complete the login action. Then inside Anchor, use the “Broadcast Transaction” option in the bottom of the sidebar:

A popup will appear, and the 3rd tab on the top allows you to Import an ESR Payload (which is what our signing requests are called).

If you paste the link you copied in the first step into that box and hit “Trigger Signing Request”, it should pop up with the Identity Request and let you approve it. Then you should see the Anchor login window in your browser close and you’d be logged in.

This process would only need to happen during login requests, and then any requests you make from the browser will automatically prompt from Anchor.

I’m not entirely sure why your computer isn’t working with these special links - which we can continue investigating, but the above at least is a method that’d allow you access to these sites right now.

I tried and it didn’t work, but luckily I deleted it and downloaded it again, I think my antivirus was blocking it
Now it’s working again
thank you very much for all the attention

1 Like