ERRORE Anchor Wallet

Hello, yesterday I tried to use my Anchor for Governance voting. I got this error ERROR: {“actor”. “Account name”, “permission”. “. Password”}.
So I tried to do other operations, but it doesn’t let me do anything, it always gives me an error of type. If I go to Airgrabs → WIZZ → claim, it gives me Airgrab error: Root coding error: invalid jsobj type, no coding method implemented ().
I can’t even send EOS to another wallet.
Do you have any idea how this can be solved? Anchor is latest version.
Thank you
Maghez

Buongiorno, ieri ho provato ad usare il mio Anchor per le votazioni della Governance. Mi è uscito questo errore ERROR:{“actor”.“nomeaccount”,“permission”.".password"}.
Ho provato quindi a fare altre operazioni, ma non mi lascia fare proprio niente, mi dà sempre errore di verso tipo. Se vado in Airgrabs → WIZZ → claim, mi dà errore Airgrab: Encoding error at root: Invalid type jsobj, no encoding methods implemented ().
Non posso neppure mandare EOS su altro wallet.
Avete idea come si possa risolvere? Anchor è ultima versione.
Grazie
Maghez

Salve Maghez. Scusa il mio italiano e molto basso, io provo :slight_smile: Posso riprodurre l’errore dal Airgrabs ma penso che non e stessa causa del problema iniziale. Se hai fatto backup per tutti i tuoi chiavi privati (private key), potresti provare a fare ripristinare l’applicazione. Vai a “Tools” e seleziona “Reset Application”.

/Johan

Thanks Johan,
unfortunately the problem is not solved. I tried on another PC, downloaded Wallet, restored backup with json, but the error is still the same. I tried to enter the private key to check the public (tools → key validator) one and it is perfect. I don’t understand what the problem is. It’s like it’s stuck.
Sorry for my English translate

Restoring a backup will likely not fix the problem, you will need to Reset the application and then import your private keys.

I got this error ERROR: {“actor”. “Account name”, “permission”. “. Password”}.

In the above, you mentioned “Password” as the permission. I think this is the issue, the permission should be active or owner in most cases. If the permission field is anything else, the account was imported incorrectly.

Hi Aaron, so I need to reset the Anchor wallet and import the keys manually. Am I right? Thanks Maghez

Correct, except you should not import them manually.

You should import them using the “Import Private Key” method to ensure it is setup correctly.

Unfortunately it doesn’t go with the private key. Yet I checked well and it’s still the same. Also if I go to tools → validator and enter the private key, it tells me it’s right. Why?

I then tried to import manually and if I try for example to vote in governance, the wallet tells me: The private key used in this wallet cannot perform the selected action.

The current private key has insufficient permissions to execute the selected action.
The authorizations of this account no longer matches the key currently imported.

  • The private key can be changed by either removing the currently wallet and reimporting the private key, or by completely resetting the wallet and rerunning the import process.

so it looks like a privat key problem, but i don’t understand why the validator then tells me it’s right. Among other things, I have the backup of this key both in photos and on a word sheet

when I transferred the eso on eosvoter … and they coincide. Alternatives? Thank you

sorry I had selected EOS not WAX as blockchain right?

Thank you Aaron

On this screen, it will also display a public key. If you take that public key (starts with EOS…) and paste it in the search box of bloks.io, does it find your account?

An example search lookup would be:

https://bloks.io/key/EOS5H3m8rs8phVQcz4GqF2NuXVREXe2QX29MGoUjMBRr8D4yyb8TH

The public key is:

EOS5H3m8rs8phVQcz4GqF2NuXVREXe2QX29MGoUjMBRr8D4yyb8TH

It shows accounts on both EOS and WAX that match that key.

Are you saying you had the wrong chain selected during the import? :thinking:

Doesn’t find the account. I have imported on eos chain. How can it be done? I’ve always used these keys … jason keys…

Looking at the account name you provided:

https://bloks.io/account/13ukgcreosda#keys

You need the private key that matches the public key of:

EOS67uLDkrYauqvRcgPjjxZGuxFcstQcVsQAfa5wZ1zsFwvj1AJNg

In the Tools → Key Validator section of the wallet, if you entered your private key and it’s not returning the above as the public key, then that isn’t the right private key. You sure you’re using the right key and don’t have another anywhere?

I looked through your account history on the explorer and the keys haven’t changed since it was created.

Thanks Aaron, tomorrow I’ll try the various hard drives. And think that I have been going on like this for years because I only held eos and therefore never had problems … of course :slight_smile:

1 Like

Let me know what you find and if you have any other questions!

Hello together,

I got a similar problem.
When I want to send EOS from anchor wallet to another account I get this error:

Error
{“actor”.“my account name”,“permission”.“my account name”}

I think I found also the problem.
When I check in the Tool-Section “permissions”, I see that the owner and active permissions have a different public key, then I connected with the anchor wallet.

When I check my account in bloks.io my account is connected with the public key I have (not the one shown as owner and active permission in anchor)
When I check the public key mentioned in the anchor wallet I just see my account name.
There is no history nothing behind that public key.

I think this is because I had an initial account and swaped from ERC-20 to the mainnet.
How can I change that permissions to the public key I have connected with my account?

Thank you very much for your help in advance!

BR

The permission field should not be your account name. It should be either owner or active.

It sounds like maybe you used the “Manual Import” option and filled it in incorrectly? I’d recommend avoiding that tool unless you’re a more advanced user. Instead you should use the “Import Private Key” method to automatically configure all the details.

If the account in Anchor is setup incorrectly, the easiest way to fix it is to remove the account and just re-add it. You can do this from the “Manage Wallets” option in the accounts dropdown (upper left). Just make sure you have the key saved externally of the wallet, remove the account, and then import it again.

Hello Aaron,

thx for your reply.

I cannot use the “Import Private Key” options.
It is just working with the manual import, where I can use
When I do I get another error “Failed to locate account”.

That is, because (I think, as I mentioned in my first post) that the Permission are connected with a different public key as with the one I have for my private key.
It may be cause of the fact, that I had a initial and I had also problems to get my EOS to the mainnet (from Exodus, I was a bit too late).

And I definitely did not get any other private key.

So it need to work with the one I have.
How I can change the public key in my actual permissions?

BR

This generally means the key you are using isn’t the correct key and doesn’t work for that account.

You cannot change the keys on an account unless you have the correct private keys.

It sounds like you’re missing the keys to the account. Whatever the public keys are that are defined on the account are what you are required to use to access and use that account.

The manual import option in Anchor doesn’t get you around this.