Remove annoying xdg-open popup for esr links? [Linux Mint]

Hey, has anyone figured out how to remove the annoying XDG-OPEN popup?
[Brave Browser / Linux Mint]

xdg-open-esr

Would appreciate if you could steer me in the right direction, or paste solution if you have it. Thanks.

There normally is an “Always open with…” checkbox you can select, but perhaps Brave has disabled that :thinking:

Brave is based on Chromium so it’s possible this may lead to a solution:

https://support.google.com/chrome/thread/14322141?hl=en&msgid=34981467

The path will likely be different since the setting is for Brave instead of Chrome, but Chromium inside of Brave is likely looking for the same value.

On another note, once Newdex integrates the session handlers supported in Anchor 1.1.0, the only time you’ll actually have to click the “Open with…” prompt is the initial login. After that, all requests will flow through the session channel and no longer use the URI handlers like being shown above.